얼마 전에 워드프레스 아바다 테마에서 간단한 용어집 페이지를 만드는 작업을 요청받아서 용어집 페이지를 하나 만들어준 적이 있습니다.

오늘 다시 연락이 와서 몇 가지 요청을 해왔습니다. 요청대로 수정을 하려고 페이지 수정 작업을 하면서 아바다 테마가 이상하게 작동하는 것을 발견했습니다.

가령, 컨테이너를 새로 하나 추가하여 텍스트 요소 같은 콘텐츠를 추가한 후에 저장을 하려고 하니 저장이 되지 않았습니다.

처음에는 아바다 버전이 낮아서 그런가 생각했습니다. Avada > System Status를 살펴보니 PHP 버전이 5.3으로 낮은 편이네요.

현재 워드프레스 권장 PHP 버전은 7.0이고, 대부분의 웹호스팅 업체에서 PHP 7.0을 지원합니다. 일부 웹호스팅 업체는 PHP 7.1까지 지원하고, Siteground 같은 업체는 PHP 7.2까지 지원합니다.

PHP 7.0 버전은 PHP 5.x에 비해 사이트 속도가 현저히 향상되었고, PHP 7.1은 PHP 7.0보다 속도면에서 소폭 향상되었습니다. 가급적 최신 버전을 적용하는 것이 속도와 보안면에서 유리합니다.

PHP 버전 업데이트 방법은 웹호스팅 업체에 따라 조금씩 다릅니다. 확실히 모르는 경우에는 웹호스팅 업체에 직접 문의해보는 것이 좋습니다.

참고: