PHP 버전을 최신 버전인 7.3으로 변경

이번 주 월요일에 이 워드프레스 블로그에 PHP 버전을 7.3으로 변경했습니다. 최신 PHP 버전으로 변경한 후 오류가 발생하는지 여부를 며칠 동안 관찰해보았지만 다행히 오류가 발생하지 않았습니다.

워드프레스가 작년 12월에 버전 5로 바뀌면서 권장 PHP 버전을 7.3으로 상향 조정했습니다. 아직 PHP 7.3을 지원하는 웹호스팅 업체가 그리 많지 않습니다.  이 블로그가 이용 중인 해외 호스팅 중 하나인 사이트그라운드(SiteGround)에서는 PHP 7.3까지 지원합니다.

지난 월요일에 Avada, Enfold, Divi 등의 테마가 설치된 몇 개 워드프레스 사이트에 PHP 7.3을 적용해보는 테스트를 진행했습니다. 아바다 테마에 포함된 레볼루션 슬라이더가 오류를 일으키는 것을 제외하고는 아무런 문제가 발생하지 않았습니다.

생각보다 빨리 PHP 7.3에 대응하여 테마와 플러그인이 업데이트되고 있는 것 같습니다.

PHP 7.3을 적용하면 속도면에서 이전 버전보다 이득을 얻을 수 있습니다. PHP 5.x에서 PHP 7.0으로 업그레이드하면 속도가 2배 내외가 빨라지는 것으로 벤치마크 결과 나왔습니다. PHP 7.3을 적용하면 PHP 7.2보다 약간의 속도 향상을 기대할 수 있을 것입니다.

이 블로그에 PHP 7.3을 적용한 상태에서 사이트 속도를 테스트해보았습니다.

워드프레스 사이트 속도

이 웹호스팅 서버의 데이터 센터 위치가 미국으로 설정된 상태입니다. 데이터센터 위치를 ‘싱가포르’로 지정하면 속도가 더 빨라질 것 같습니다. 속도 측정은 Pingdom Speed Test 툴을 활용했으며 테스트 서버를 ‘일본 도쿄’로 지정하여 진행했습니다.

아직도 PHP 5.x를 사용하는 경우 PHP 7 이상 버전으로 업그레이드하는 것이 좋습니다. PHP 5.x는 2019년 1월 1일에 수명 만료일(End-of- Life: EOL)이 도래하여 더 이상 보안 패치가 제공되지 않습니다. 그러므로 가급적 PHP 7로 업그레이드하는 것이 좋습니다.

참고:

2 thoughts on “PHP 버전을 최신 버전인 7.3으로 변경”

  1. 안녕하세요 😉

    호스팅 업체를 통해서 PHP를 7.3 으로 업데이트 한 후부터 홈페이지 접속이 안됩니다.

    Fatal error: Cannot use “self” when no class scope is active in /host/home1/hyesungch/html/wp-content/themes/Avada/framework/plugins/importer/importer.php on line 1000
    There has been a critical error on your website.

    Learn more about debugging in WordPress.

    이런 에러가 뜨네요 ㅠㅠ 왜이럴까요?

    응답
    • 아바다 테마와 플러그인, 워드프레스도 모두 최신 버전인가요?

      최신 아바다 테마에서는 PHP 7.3을 지원할 것 같습니다. 만약 아바다와 플러그인, 워드프레스를 모두 최신 버전으로 업데이트해도 문제가 발생하면 PHP 7.2로 다운그레이드하면 문제가 발생하는지 체크해보세요. 또한, 아바다 관련 플러그인을 제외한 모든 플러그인을 비활성화하여 문제가 해결되는지도 체크해보시기 바랍니다.

      응답

Leave a Comment