현재 이 블로그가 호스팅되고 있는 사이트그라운드에서는 PHP 7.2까지 지원하고 있습니다. 어제 PHP 7.2를 적용해보았습니다.

혹시 사이트가 오류로 인해 작동하지 않을까 염려했지만, 우려와는 달리 아무 이상 없이 작동하네요.

아바다Enfold, 그리고 Divi를 각각 사용하는 다른 블로그에도 PHP 7.2를 적용했는데, 모두 정상 작동하고 있습니다.

워드프레스의 권장 PHP 버전을 PHP 5.6에서 PHP 7.0으로 상향 조정할 때에는 제법 시간이 걸렸고, 오류가 나는 테마나 플러그인이 많았지만, PHP 7.0에서 PHP 7.2로는 별 어려움 없이 변경되는 것 같습니다.

현재 워드프레스의 권장 PHP 버전은 PHP 7.2 이상입니다.

우리나라의 경우, 카페24에서는 PHP 7.0까지 지원됩니다. PHP 7.2까지 지원하려면 조금 시간이 걸릴 것 같습니다.

PHP 5.x에서 PHP 7.0으로 업그레이드하면 사이트 속도가 크게 향상됩니다. 그리고 PHP 7.1과 PHP 7.2를 적용하면 조금 성능이 향상된다고 하네요.

참고: